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Dreamweaver MX is a powerful Web authoring tool. If you have previously used Dreamweaver will ýnd little change in the 
way of working in the MX version. However, there are interface changes that will enable you to work more efýciently.

Making the transition from Netscape Composer is also a simple process. The principles used are all the same. However, 
Dreamweaverôs more advanced capabilities provide superior functionality and efýciency. Additionally, the site management 
features help prevent linking problems that typically occur when working in Netscape.

previewing & testing pages
> previewing pages
Though Dreamweaver is a WYSIWYG ï What You See Is What You Get ï editor, it is essential to preview pages in a browser. 
Some things will look slightly different when viewed in the browser, and links can only be tested through the browser. 

Dreamweaver makes previewing pages easy. Simply hit the F-12 key to view the page in Internet Explorer. Thereôs no need to 
save the page each time before previewing.

> testing in multiple environments
Since the Web is designed to work for users no matter what kind of computer they are using, ideally you should preview your 
pages on both PC and Macintosh machines. It is also best to check pages in Internet Explorer, Netscape and America Online. 
Unfortunately, within the PISD environment, we are limited to testing pages on the PC and in Internet Explorer. Once your 
pages are posted, try to review your site from outside the district network using different machines.

> checking screen resolution 
Screen resolution is the single most signiýcant variable affecting what different users of a site will see. It can have a dramatic 
impact on how a page displays. 

With PISDôs Windows 2000 upgrade, itôs easy to monitor the effects that common screen resolutions have on your pages. To 
change resolutions, look in the System Tools folder of the application launcher. Double-click an icon to change resolutions 
without restarting.

< building websites with dreamweaver mx >
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< touring the mx interface >
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<  document window >
This is the work area where you actually create your document. When the document window is maximized, it includes a tab 
on the lower left with the ýle name of the document. If you have multiple pages open, you can click the tabs to switch from 
one page to another.

<  menus >
Virtually every task can be achieved via the menus at the top of the window. However, as in other Windows programs, there 
are alternative ways of accomplishing most tasks.

<  insert bar >
On initially installing Dreamweaver, the Insert Bar is displayed by default immediately below the menus (not shown above). 
Most of the icons on the Insert Bar are used by authors creating creating database-driven sites. Save valuable screen real 
estate by closing it. Go to Window > Insert and deselect.

The Dreamweaver MX interface is easy to understand if you take it a section at a time. To manage the workspace most 
efýciently, set the monitorôs screen resolution to 1024 x 768.
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< touring the mx interface = continued >

<  toolbars >
To add a toolbar with the common icons for such tasks as creating a new document, saving, copying, pasting, etc., choose 
View > Toolbars > Standard. 

If you want quick access to view your HTML code, display the Document toolbar (not shown).  Choose View > Toolbars > 
Document.

<  panel groups >
On the right side of the screen are several panel groups. These can be expanded and collapsed by clicking on the triangle 
on the left-hand side of the title bar for each panel. The Files panel group will be the most frequently used and should be 
expanded most of the time. You will never use the Application panel. To close it, right-click on the Application title bar and 
choose Close Panel Group.

<  property inspector >
The Property Inspector is the most important component of Dreamweaver. This context-sensitive tool enables you to view and 
modify the properties of most items included in your page.

<  status bar >
The area beneath the document window contains useful information. 

On the lower right is an indication of the total page weight (ýle size including the HTML page and any image ýles included) 
and the estimated download time at 56K. Be sure to check the download time for each page. Design experts suggest that 
effective pages should load within eight seconds.

Just to the left of that is the size of the document window. If the document 
window is maximized, you have no other control of that sizing. However, if it 
is not maximized, you may click on the size settings and choose an alternate 
document window size from the pop-up menu. This allows you to simulate the 
view that users have at different screen resolutions.

At the far left side of the status bar is the Tag Selector. Once you learn basic 
HTML code, this is a handy tool. Until then, ignore it.

tag
selector

page weight/
download time

window
size
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< deþning the site >

To work in Dreamweaver you must deýne a site. This tells Dreamweaver in which folder the ýles for this site will be stored. 

1 Create a folder where all your web ýles will be stored. If you already have images that youôll use in your site, put the 
images in this folder as well.

2 Choose Site > Deýne New Site and then select the Basic tab.

3 Give the site a name that is meaningful to you. (This will show only as youôre working in Dreamweaver.) Click Next. 

4 Choose No, I do not want to use a server technology. Click Next. 

5 Choose Edit local copies on my machine and then upload when ready. 

6 Click on the folder icon and browse to the folder where the websiteôs ýles will be stored. Click Select.

7 Answer the question How do you connect to your remote server? by choosing None. Click Next. 

8 A screen will display the settings you have chosen. Click Done. 

Dreamweaver will scan the ýles to build a cache so that it can efýciently track changes 
that you make to your site. When it ýnishes, all of the siteôs ýles will be listed in the Site 
panel.

The Site panel (shown at right) allows a simple way to make links to other pages within 
the website. Simply point and click to establish foolproof links as described on page 11. 
Additional power from the Site panel is available as you use its site management features.
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< starting a page >

By default, Dreamweaver opens each time with a new blank page. When you need to start additional pages, choose File > 
New. When presented with choices, select Basic Page, HTML to get a blank page.

saving the page
Get in the habit of immediately saving your ýles into your siteôs folder. This is critical because links to images and other 
HTML ýles cannot be properly written until the ýle is saved. Remember these rules when naming web ýles:

> File names may not include spaces.
> File names should not include special characters other than hyphens and underscores.
> File names may not exceed 31 characters.

page properties
From the menu choose Modify > Page Propertiesé 

page title -  An essential item to include on every page. 
The title will show in the title bar of the web page, will show 
up in search engine results lists and will display in usersô 
Favorites lists. 

background image - To use a background image on the 
page, click on the folder icon and browse to select an image 
ýle. 

colors - Set page background color, text color and link 
colors by clicking on the appropriate color chip and then 
selecting from the palette.

margins - Margin settings may be added if desired. The 
normal usage for these margin settings is to allow content to 
butt against the top and left edges of the browser window. To 
achieve this effect enter value of 0 in all four margin ýelds.
  

head tags
Content in the Head tags is not actually displayed on the page. However, such content is important to a pageôs functionality. 
There are two head tags that each page should include:

> description
This is a brief summary that is displayed by search engines when your page is located in a Web search. Choose Insert > Head 
Tags > Description and type a short explanation of the pageôs contents.

> keywords
Keywords aid search engines in classifying the page and locating it as an appropriate match for Web searches. Choose Insert 
> Head Tags > Keywords and list a short series of words that will help categorize the pageôs contents. Separate words or 
phrases by commas.
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Start by just typing in text or copying and pasting from an existing word processing document. Though Dreamweaver 
functions much like a word processor, due to the requirements of HTML, there are some limitations.

formatting text
The Property Inspector for formatting 
text is easy to master. Highlight a text 
selection on the page and then apply the 
font and text settings in the Property 
Inspector as described.

1 format ð This list allows you to 
select an HTML heading size or the standard paragraph formatting. It is acceptable to ignore this ýeld entirely.

2 font ï Choose a font set from the list. (See explanation below for using fonts not in the list.)

3 size ð The font sizes you select from this list are based on HTML font speciýcations. HTML documents use relative font 
sizes. This means that the font sizes will vary depending on the font settings speciýed in the userôs browser. A size of 3 is 
the default text size (2 is smaller, 4 is larger).

4 color ð Click the color chip to select a color from the palette or type a hexadecimal color code in the accompanying ýeld.

5 style ð Click to select bold or italic. There is no underline option on the Property Inspector since only links should be 
underlined on a web page. (If you are editing a page that has an existing underline that you need to remove, go to the 
menu and choose Text > Style > Underline.)

6 alignment ð Select appropriate alignment from the four button options.

7 link - Use to link text to a URL or local ýle. (See explanation on page 11.)

8 bullets/numbered items ð Select button to apply bullets or numbered lists. Use the List Item button to modify the 
bullet or number style.

9 indent/outdent ð These buttons apply formatting to an entire paragraph. They do not allow you to independently 
indent/outdent the ýrst line of a paragraph.

using the font sets
By default, Dreamweaver lists only choices of the fonts most commonly used on web pages. Since fonts arenôt actually 
embedded in HTML ýles, the page is dependent on the selected font being resident on the userôs computer. Consequently, it is 
important to use fonts that are found on almost all PCs and Macintoshes. HTML allows authors to list alternative font choices 
in their code. This is why you see multiple fonts listed when you choose one of Dreamweaverôs 
font sets.

It is a simple procedure to create additional font sets.

1 Start by choosing Edit Font List.

1 2 3 4 5 6

7 8 9

< working with text >

1
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< working with text = continued >

html styles
HTML styles provide an efýcient method for consistently formatting text throughout your 
website. When you create an HTML style specifying font and style settings, those same settings 
can be applied to any text within the website at the click of the mouse. 

To create and use HTML styles:

1 Open the Design panel and select the HTML Style tab.

2 Select text on the page that is already formatted to duplicate its style.

3 Click the New Style button on the Styles panel.

4 Give the style a name.

5 Review the settings and see if there are any that should be changed. Click OK.

6 The name of the style will appear in the Styles panel.

7 To apply the style to the text, ýrst select the text on the page.

8 Click the style name in the HTML Style panel.

9 The style attributes are applied to the text.

The HTML style will be available to apply to any page within the website. Though HTML styles 
are a useful tool, they do not provide the same functionality as styles in a word processor. If you 
change a style deýnition later, it will not update text that has had the style previously applied.

As you progress in your skills, you may wish to use Cascading Style Sheets. CSS allow you to 
modify styles and then update your entire site instantaneously. Cascading Style Sheets is now the 
professional standard for formatting web text. If you are starting a new site, consider using CSS. 

4

5

8

3

1

2 Select a font from the list of Available Fonts.

3 Click the left arrow.

4 The font will be listed under Chosen Fonts.

5 Repeat the process to specify alternative fonts for 
users who do not have the ýrst choice font. You 
may list multiple fonts, but your ýnal choice should 
always either be serif or sans-serif to provide a 
generic alternative.

6 Click OK and the new font set will be added to 
your listing.

Among the fonts that are reasonably safe to use are 
Trebuchet MS and Comic Sans MS.

4 3 2 6
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Currently only two graphics ýle formats are consistently supported on the Web. All images should be either GIF ýles or JPG 
ýles. These ýle formats are highly compressed so that the images will download more quickly. If it is necessary to include an 
image that is saved in another graphic ýle format, convert the image to a GIF or JPG using an image editor such as Fireworks 
or ImageBlender.

When you insert an image into a Web page, the image doesnôt actually become a part of the HTML ýle. Rather, the 
HTML ýle includes instructions telling the browser where to display the image on the page and at what size to display it. 
Consequently, there are important considerations to keep in mind:

> When putting your pages on a Web server you must also upload all the image ýles to the server. The ýles must be in the 
same location in relation to the HTML ýle as when that Web page was created. The easiest way to do this is to make sure 
all image ýles and HTML ýles are in the same folder.

> Download time for an image is based on the ýle size of the image. If you insert a large photo on your page and have 
the browser display it as small, it will take an unnecessarily long time to download. Use an image editor to make size 
adjustments to an image.

Dreamweaver is designed to seamlessly integrate with Macromediaôs Fireworks. When you create images in Fireworks and 
save the original source ýle of the image, you can modify the image at any time by simply clicking the Edit button on the 
image Property Inspector in Dreamweaver.

< how images work on the web >
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< working with images >

1

7 8 9 10 11

65432

inserting an image
The Assets panel displays all the images located in your site. 

To place an image on your page, simply locate the image in the Assets panel and then drag it 
to the page.

adjusting image properties
When the image is placed on the page, image properties are displayed in the Property 
Inspector. 

1 thumbnail ð A thumbnail of the image is shown along with the ýle size. 

2 w & h ð Display height and width of the image in pixels. Though it is possible to change 
the dimensions at which the image displays by altering the numbers in the W and H 
ýelds, it is rarely a good idea. Resize your images in an image-editing program.

3 link ð Insert URL or path to a ýle 
within the site. See explanation on 
page 11.

4 src ð Shows the ýle name of the 
image (and the path if it is located 
in a subfolder).

5 edit ð Launches Fireworks and 
opens the original source ýle of 
the image (if available) to allow 
efýcient image editing.

6 alt ð Enter a few words to tell what the image is.  Alt text is especially important for the visually impaired whose text-
reading browsers describe images by using the Alt text. (For images such as custom-made bullets and spacers, select 
<empty> from the drop-down list so that the text-reading browser will ignore the image.)

7 map ð Use this section to turn an image into an image map. This is a simple process, but it is not detailed in these 
instructions.

8 v space/h space ð You may specify a number of pixels of space vertically and/or horizontally around the image. This 
gives the image ñbreathing room.ò

9 border ð Specify a width in pixels if you desire a border around the image. The border will be black unless the image is 
also a link.

10 alignment buttons ð Controls the horizontal alignment of the image. However, the image cannot have a different 
alignment than text or other images on the same line unless they are placed in different table cells.

11 align list ð Choose how the image aligns vertically with adjacent text or images.

Click the assets tab to display the 
assets panel. Drag the ýle name or 
thumbnail onto the page to place 
the image.

assets tab
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Type in a complete URL for links to sites outside of your website. It works the same way in the Property 
Inspector for both images and text.

To link to a ýle within your website, click the Point to File icon and drag the arrow. Release on the ýle 
to which you wish to link.

linking to another site 
on the web
To link either text or an image, select 
the text or image that will be linked. In 
the link ýeld on the Property Inspector, 
type the complete URL to which you 
wish to link. Be sure that you start your 
URL with http://

To ensure accuracy it is a good idea to 
copy and paste long URLs. However, thereôs only one way to successfully paste a URL into the Property Inspector. Right-
click on the Link ýeld and choose paste. The URL will be inserted. If you use another method of pasting, it will paste over the 
text or image on your page instead of pasting into the link ýeld.

linking to another page 
on your site
Link using either the Point to File icon 
or the Folder icon located next to the 
link ýeld on the Property Inspector. 

> To use the Point to File method, 
click on the icon and drag the 
arrow to the appropriate ýle in the 
Site Files panel.

> To use the browse to ýle method, 
click on the Folder icon and browse 
to select the proper ýle. Click OK. The ýle name (and path, if applicable) will be added to the Link ýeld.

< making the link >
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linking to another place on the same page 
It is occasionally helpful to build links within a single page to help the reader locate information quickly. This is most useful 
if the page requires extensive scrolling. For example, list contents of the page with links to speciýc information that is located 
farther down on the page.

1  create an anchor
Before linking to another spot within the page, it is necessary to create an anchor to link to. (For example, if providing a 
link that will say, ñReturn to top of page,ò place an anchor at the top of the page.)

a Click on the spot to add an anchor (e.g. at the top of the page).

b Choose Insert > Named Anchor from the menu.

c Enter a name for the anchor. In this example, enter top since it will bring the user back to the top of the page. (An 
anchor name cannot include spaces.)

d An anchor symbol will show on the page to indicate that an anchor has been placed there. (This only shows in 
Dreamweaver. No indication of the anchor is shown on the Web page itself.)

2  add the link
After creating the anchor, make a link to it in much 
the same way as any other type of link.

a Highlight the text to link from (e.g. Go to 
top of page).

b Click the Point to File icon.

c Drag to the anchor symbol and release.

d The link path will be inserted on the link line of 
the Property Inspector.

The link on the page will now be active and ready to test 
in the browser.

email links
You can add a link that includes an email address. It is considered proper form to visibly include the email address on the page 
in addition to making that text into an email link.

1 Highlight the text or image that you wish to link.

2 On the Link line of the Property Inspector type in  mailto: followed by the email address to which you will link. 
(Donôt put a space before or after the colon.)

3 Test the link in the browser by hitting the F-12 key.

< making the link = continued >
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< formatting with tables >

inserting a table
Choose Insert > Table. In the dialog window, specify table properties:

> width ð May be speciýed in either pixels or as percentage of the 
browser window. (If creating a nested table, value is percentage 
of parent cell.) 

> cell spacing ð Pixel values may be speciýed for the amount of 
space between cells.

> cell padding ð Pixel values may be speciýed for the amount of 
space between the cell border and the contents of the cell.

> border width ð Specify pixel value. Enter 0 if a borderless table is desired.
 
Click OK to add the table to the page.

adjusting table properties
The Property Inspector reþects the current table properties. It also allows adjustment to these properties as long as the entire 
table is selected. (If table is deselected, click on the outside border of the table to select it again.) 

1 rows ð If you change the number of rows, they will be added to or deleted from the bottom of the table.

 columns ð If you change the number of columns, they will be added to or deleted from the right side of the table.

2 w & h ð Adjust width/height of entire table in absolute pixels or as a percentage of browser window or parent cell.

3 cellspace ð Adjust cell spacing.

4 cellpad ð Adjust cell padding.

5 border ð Adjust border width.

6 align ð Change table alignment on 
the page.

7 clear table height/width 
- Buttons that clear table height 
and width values. These buttons are useful if tables become unmanageable after resizing columns or rows. They give the 
opportunity to ñstart overò by resetting those properties.

8 bg color ð Change the background color of the table by clicking on the color chip.

9 bg image ð Add a background image to the table. Use this option with caution. Though Internet Explorer will use the 
image as a single background image for the table, Netscape will add the background image to each individual cell.

10 brdr color ð Change the tableôs border color by clicking on the color chip.
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1 2 3 4 5 6 7 8

modifying table components
After inserting a table, you will often need to make modiýcations to individual rows, columns or cells. 

> To add columns and rows in locations other than at the bottom or right of the table, choose Modify > Table > Add 
Columns or Rows.

> To delete an entire row or column, drag across the entire group of cells and then click the delete key.

When you click inside a table cell, the top half of the Property Inspector displays text properties and the bottom half displays 
table cell properties. You can modify properties for an individual cell, or by clicking and dragging across cells, modify 
multiple cells at once. The different elements you can control on the Property Inspector are:

1 merge cells ð Highlight adjacent 
cells and click the button to merge 
cells.

2 split cells  ð Click inside a cell 
and then click button to split cell. 
In the dialog box, specify the 
number of rows or columns by 
which to divide.

3 horz ð Specify the horizontal alignment for a cell in this drop-down list. Choices are Left, Right, Center or Default.

4 vert ð Specify vertical alignment of the cells. Top, Middle, Bottom or Default.

5 w ð Enables you to specify width of a cell.  Cells may either be set in pixels by entering a number or as a percentage 
width of the table by entering a number followed by the % symbol. (Since all cells in a column must be the same width, 
only one needs to be speciýed.)

 h ð Enables you to specify height of a cell. Cells may either be set in pixels by entering a number or as a percentage 
height of the table by entering a number followed by the % symbol. (All cells in a row must be the same height.)

6 bg ð The Bg next to the color chip allows selection of a background color for the cell.

7 bg ð Applies a background image for the cell. Click on the folder icon and browse to the image which must reside in the 
folder for the current website.  

8 brdr ð Allows speciýcation of a border color for the cell.

formatting with tables
Table formatting is an important tool in page design. To use invisible tables for advanced page layout, set borders to 0. Table 
boundaries will be indicated with dotted lines while working in Dreamweaver but will not show in the browser.

> Cells without content will collapse in many browsers. If you need an apparently empty row or column, use a transparent 
spacer image in one cell of that row or column.

 Insert a 1-pixel by 1-pixel transparent GIF in the cell you need to hold open. Adjust dimensions of the image in the 
Property Inspector to the desired height and width to prop open the cell. For example, if you need to hold a column open 
100 pixels wide, insert the single pixel and change the image size to 1 pixel by 100 pixels. 

< working with tables = continued >




